LOGIN  |  REGISTER
Smart Living Made Brilliant!
CASTLEOS FORUM

rpiwally

all messages by user

9/26/2015
Topic:
API

Michael Wallace
Michael Wallace
Chris, when with the 2.0 API be released?
10/21/2015
Topic:
CastleHUB Updates - July 29th

Michael Wallace
Michael Wallace
Chris, what was the highest order number fulfilled in this shipment?
10/22/2015
Topic:
CastleHUB Updates - July 29th

Michael Wallace
Michael Wallace
I just received a UPS email for delivery tomorrow(CA). I was pre-order number 1225 if that helps anyone (August).
10/23/2015
Topic:
API

Michael Wallace
Michael Wallace
Any update on this Chris? Halloween fast approaches.
10/23/2015
Topic:
Zigbee ?

Michael Wallace
Michael Wallace
Chris Cicchitelli wrote:
Right now the Philips Hue ZigBee bridge is supported, and we'll be adding support for USB ZigBee radios as well in the future.


Do you have a rough timeline on this? I feel that having 802.15.4 integration (whether it be Zigbee, Thread, or both) will be key.
10/23/2015
Topic:
Amazon Echo

Michael Wallace
Michael Wallace
Anything new on the Echo front? Also, will having the voice remote for Fire TV have the same effect as a full up Echo?
10/23/2015
Topic:
Harmony Hub

Michael Wallace
Michael Wallace
Any plans to add the harmony hub? When I was using the StackBox, there was a way to get some information from it. I feel like it was a json call in a REST API. It could have been the StackBox, but if I recall correctly, it was one of the few things that used a REST API vice python calls. Available functions included starting an activity, turning everything off, seeing the active activity, and getting a list of activities.

Mike
10/26/2015
Topic:
How-To Guide Requests

Michael Wallace
Michael Wallace
Andrew Sinclair wrote:
Can you please just post up to date documentation with al the devices and serial numbers supported. If you want this to go mainstream you need to document!

http://castleos.com/CompatibleDevices.aspx
Note the links to the items...
10/27/2015
Topic:
How-To Guide Requests

Michael Wallace
Michael Wallace
Andrew Sinclair wrote:
Does it or does it not work with sonos?I just hot the hub (kickstarter backer) and the app says media is coming soon. I thought this was supported.

https://castleos.com/forum/topic260-sonos-support.aspx



Try searching the forums vice the wiki. Chris answers many questions in here.
10/31/2015
Topic:
API

Michael Wallace
Michael Wallace
Chris, I see the new version is out. Is there a how-to on the new API? Is it a straight REST API? Is this still the location for every command http://localhost/CastleOS/service?wsdl ? My Hub also does not seem to have had its license activated yet. Can you help me out with that? Thanks again.
11/14/2015
Topic:
Kinect Service not authenticating

Michael Wallace
Michael Wallace
Chris,

I am attempting to setup a Kinect 1414 on a different computer from the CastleHub. When I type in the credentials, I get a straight up Authentication Failed popup (repeatedly). It does not prompt me for an IP address for the core service computer. I remember the previous version did work correctly and asked for the IP. Is it possible to get that installer?

On another note, I am setting this up on the new Intel Compute Stick. THE KINECT 1.8 SDK DOES NOT INSTALL ON WIN 10. I was able to revert it to 8.1 and install the SDK before reupgrading to 10. FYI.

Thanks in advance,

Mike
11/24/2015
Topic:
API

Michael Wallace
Michael Wallace
Any update Chris? It's been 4 weeks now.
11/29/2015
Topic:
Kinect Service not authenticating

Michael Wallace
Michael Wallace
Finally got around to working on it. Manually editing the config file made it see the CHub, but I ended up just uninstalling and clearing the ProgramData, AppData/Roaming, and Program Files folders. After reinstalling, everything works perfectly now. No other issues using the Intel Compute Stick. It seems to make for a decent mini-pc for remote rooms for Kinect use.
11/29/2015
Topic:
HUB RAM

Michael Wallace
Michael Wallace
llopez799 wrote:
Hi Chris,

I have purchased and installed the RAM you provided the link for. When attempting to boot-up my hub, I get nothing other than a beeping noise from the hub. Please advise.

Thanks,
Luis


Luis,

How many beeps and how fast? Usually indicates the specific error. Though my guess is either the RAM is seated incorrectly or you have a bad RAM chip.

Mike
(A+\Network+)
12/1/2015
Topic:
Kinect Service not authenticating

Michael Wallace
Michael Wallace
On sale for $99.99 at Newegg. http://www.newegg.com/Product/Product.aspx?Item=N82E16883800004&cm_re=Compute_Stick-_-83-800-004-_-Product


I've been having trouble re-upgrading to 10 though (Comes with 8 with Bing (32 bit). Upgraded to 10. Had trouble getting Kinect SDK on. Reverted to 8. Everything is now working. Would like to re-upgrade to 10).
12/6/2015
Topic:
HUB up...sort of. Some Observations and Questions

Michael Wallace
Michael Wallace
Videobear, try this: http://www.realvnc.com/download/ Download VNC onto the hub (use the service mode). You will need a keyboard and mouse for this. HOWEVER once it is installed and setup, you can use VNC viewer on your desktop to see and operate the hub from your desktop. This is what I use.
12/8/2015
Topic:
What is it on the hub?

Michael Wallace
Michael Wallace
wolfpaw,

Just type the Hub's IP address into your phone app or the browser of another computer on the network. If on the hub, just type localhost into the URL.
12/8/2015
Topic:
API

Michael Wallace
Michael Wallace
^ What he said
12/9/2015
Topic:
Adding Z-wave Devices

Michael Wallace
Michael Wallace
Try restarting the Hub. That usually worked for me when that would happen (devices not showing up).
12/12/2015
Topic:
API

Michael Wallace
Michael Wallace
I see the update Chris. Does this release have the new API exposed? Is it in the same location as before? Thanks.