LOGIN  |  REGISTER
Smart Living Made Brilliant!
CASTLEOS FORUM

HomeGeneral Support

The general support forum topic for CastleOS - ask questions, get help, and more

Event to turn Off lights Messages in this topic - RSS

Dasler
Dasler
Posts: 18


7/11/2017
Dasler
Dasler
Posts: 18
Hi, I am trying to setup 1 recurring event to turn off the lights.
As you probably know the zigbee smartlights (Hue,Osram) come back On after a power outage.

I just want to prevent a waste of money/energy in the event that happen while I am away.

This is what I tried.

Event type - Schedule
Schedule type - recurring
Start date - Tuesday Jul 11 2017
End date Thursday Jul 13 2017
Occurs At 730 PM
Recurs every - 1 minute
Next schedule run time - 7/12/2017 @ 7:13pm - dont know why it default to the next day, if I selected every 1 minute.
Last run time 1/1/0001 1200am
Actions
Hue devices - hue color 2, Off
Voice announcement to all speakers
Conditions - none


that was just a test I will change the start time and end time.

would something like this be possible?
basically what I want is castleos to make sure the lights are off during the time that I would normally have them off, during the daytime and past 1040pm.

thanks.
0 link
Dasler
Dasler
Posts: 18


7/15/2017
Dasler
Dasler
Posts: 18
Anyone had tried this.
0 link
Chris Cicchitelli
Chris Cicchitelli
Administrator
Posts: 3366


7/15/2017
Chris Cicchitelli
Chris Cicchitelli
Administrator
Posts: 3366
Hi Dasler, this event should work like you are thinking. But instead of doing it as a scheduled event, I would make it a triggered event. Have the event run each time your bulbs turn on, with the action to turn them off, and then add the condition that they will only do so if it's during the times that you want.

So your device trigger is the bulb, and your action is the bulb. Let me know if you need more info!
0 link
Dasler
Dasler
Posts: 18


7/16/2017
Dasler
Dasler
Posts: 18
update:
event type: device triggered

last run time: 1/1/001 1200am
event trigger: hue color lamp 2 turns on
actions:hue devices- hue color lam 2 turn, Off
voice announcement to all speakers
conditions: and time is between 11:00pm and 11:59pm
and time is between 12:00am and 8:00pm
--
I did not get the voice announcement so I suppose castle os knows the light is not turning Off.

I turned the light on and I see that the Icon appears on the Device tap in caslte os, after a few seconds the icon disappears telling me that the light is Off, but the light is still On. sometimes after a few more second the icon appears back in the devices tap in castle os telling me the light is on.
For some reason is not turning the light Off, and I event lost the connection to the light if I try to turn it off from homekit. after a while I regain connection to the bulb.

also it seem almost impossible to connect to the castleos service using the iPhone, I was only able to see the log in screen 1 time and after I tried to log in, it went back to the white screen safari could not open the page because the server stopped responding.
I been trying to log in for about 10min the loading bar move super slow and then it stop.
0 link
Chris Cicchitelli
Chris Cicchitelli
Administrator
Posts: 3366


7/16/2017
Chris Cicchitelli
Chris Cicchitelli
Administrator
Posts: 3366
The way you designed your conditions would prevent it from ever running, it will never be between 11 and 1159 AND 12 and 8, it will only be one of those two.
0 link
Dasler
Dasler
Posts: 18


7/16/2017
Dasler
Dasler
Posts: 18
that explain, I removed the one from 11 to midnight and now is turning the light Off almost instantly. super!
so would I have to create a second one but this time from 11pm to 1159pm?

also how do I setup castle os to come back on after a power outage.
the computer is already setup this way but castle os don't auto launch.
windows 10.

I use this same topic to ask:
1. how do I change the tts announcement, I would like it to say the name of the device, on off, custom text.
2. is there anyway to know if the system hear you, like Yes sir... etc.

ty.
0 link
Chris Cicchitelli
Chris Cicchitelli
Administrator
Posts: 3366


7/16/2017
Chris Cicchitelli
Chris Cicchitelli
Administrator
Posts: 3366
Just add that as a condition, but instead of "and", make it "or".

CastleOS should be set to power on automatically, but you can change this in Windows Start Menu > Services > CastleOSCoreService (right click, select properties, then adjust the startup settings).

The TTS announcement can be changed by clicking the icon next to the announcement in Actions in the Event (during add or edit event). A box will pop up that you can change the TTS message.

The system will ding when it hears you, or verbally reply without a ding, depending on the command you give it.
0 link
Dasler
Dasler
Posts: 18


7/16/2017
Dasler
Dasler
Posts: 18
after I added the '' or '' time condition it seem that now is not turning the light off anymore. I added it to the same event.
or it have to be a completely new event?

I looked at the setting and it show automatically, question so it don't have to be actively open in the Internet Explorer windows for it to work?
because when I hard restart the computer the Internet explorer don't auto open.

I was able to change the tts.

Thanks.
0 link
Chris Cicchitelli
Chris Cicchitelli
Administrator
Posts: 3366


7/17/2017
Chris Cicchitelli
Chris Cicchitelli
Administrator
Posts: 3366
Nope, same event is correct. Can you send a screenshot of your event settings as they currently are?

Regarding the user interface (UI) in the web browser, this doesn't need to be open for CastleOS to run. That is just the front end, CastleOS' backend starts when the computer starts and runs in the background.

Thanks!
0 link
Dasler
Dasler
Posts: 18


7/18/2017
Dasler
Dasler
Posts: 18
[IMG]http://i63.tinypic.com/15evmv4.jpg[/IMG]
I removed the 2nd condition of '' or '' with 1100pm to 1159pm as it was not working.

just now I was testing it and is not turning the light off, only if I try to turn the light On from castle os then it recognize the event and turn it off immediately.
but if I turn the light on from the wall, homekit or hue app is not working like before.

I have another question I cannot find how to add light to a group.
under edit it dont give me the choice to add them.

Regarding the user interface (UI) in the web browser, this doesn't need to be open for CastleOS to run. That is just the front end, CastleOS' backend starts when the computer starts and runs in the background.

thanks for that, I was wondering why it was not opening in internet explorer, but like you say is running in the background I saw it in task manager.
0 link
Chris Cicchitelli
Chris Cicchitelli
Administrator
Posts: 3366


7/18/2017
Chris Cicchitelli
Chris Cicchitelli
Administrator
Posts: 3366
To add a light to a group, edit the light, there are three groups you can add it to. Devices > Menu > Edit Device or Settings > Edit Device.

I'm not sure why the light event wouldn't be working as before unless something else changed? No matter how you adjust the lights, the API will report on/off/dim accordingly the same way. So the only reason the event wouldn't trigger is if the condition prevented it, or if the API didn't say the light status changed. In Settings > Menu > View Logs, you can see if the system is running the event. That will tell you if it's running and not working, or not running at all.
0 link