LOGIN  |  REGISTER
Smart Living Made Brilliant!
CASTLEOS FORUM

recent posts recent posts - RSS

15 hours ago
Topic:
Kinect V2/voice control/ and your future direction

Robert Sims
Robert Sims
Posts: 3
Any thoughts?
3 days ago
Topic:
Kinect is officially dead

Kevin Mathews
Kevin Mathews
Posts: 132
Chris Cicchitelli wrote:
Not at all! CastleOS 2.0 turned into a larger redesign, and it's almost complete. We're even building a new app for controlling the system, and making the Core Service cross-platform capable. Next beta coming the first week of the new year!


How is this update coming? Is the new app available? I am wondering if it will help my issue of the dimmer control unavailable on my Samsung S7 (see this post: https://castleos.com/forum/topic1084-android-app-has-no-dimmers.aspx?lastpage=1#post8538 ).
3 days ago
Topic:
Zigbee ?

Kevin Mathews
Kevin Mathews
Posts: 132
Kevin Mathews
Kevin Mathews
Posts: 132
Topic: Zigbee ?
Is this dual-protocol USB stick supported yet (I assume it is the Linear/Nortek HUSBZB)?
7 days ago
Topic:
New Installation

Michael Smith
Michael Smith
Posts: 3
Hi. First, I installed the latest GD release and received the message. Then, after tinkering a bit I thought I would try the beta. When the result was the same I installed CastleOS, did not delete the folder, and re-installed with the same result. Then, placed a comment on the board for help. If you need me to manually edit a file I can do that without issue. The goal obviously is to gain access to the settings options. Thanks.
8 days ago
Topic:
New Installation

Chris Cicchitelli
Chris Cicchitelli
Administrator
Posts: 3376
Chris Cicchitelli
Chris Cicchitelli
Administrator
Posts: 3376
Topic: New Installation
Hi Michael, it's possible to manually change a file so the error message will display. Which version did you install? The regular one or the beta?
8 days ago
Topic:
Cannot access settings since upgrade

Michael Smith
Michael Smith
Posts: 3
What did you do to correct this issue? My settings page has not worked since installation.
edited by mike-smith on 1/15/2018
8 days ago
Topic:
New Installation

Michael Smith
Michael Smith
Posts: 3
I just installed CastleOS on my Windows 10 notebook and all appears to have gone well. However, when I click on the settings button I get an error message, see attached. Any ideas on how to resolve this issue?
9 days ago
Topic:
Multi Zone Kinect Service.

kent sager
kent sager
Posts: 10
I purchased a small fanless box to run a remote Kinect. It was up working fine for a few days. Today, it was powered up but no voice response. Took box to my office and hooked up different Kinect. Now the config screen shows two Kinects in the multizone settings and neither one work. How do I revert back to the basic Kinect service?
10 days ago
Topic:
Android app has no dimmers

Kevin Mathews
Kevin Mathews
Posts: 132
This happened a while ago, and frankly I didn't think it was worth the battle to get help, but thought I'd get it out there.

When I first downloaded the Android app, all worked well for the initial release, at that time, the dimming rings on long-press worked GREAT (still would rather have linear swipe to control the rotary dimmers). A while back I noticed the long-press no longer brought up the dimmer controls. I lived with it a while but now just tried deleting and reloading the app from Google Play, still inop.

Nothing has changed in my devices, and all of them dim if I go through the device list and pull down the number panel for dimming percentages. Also the dimming rings show up and work as designed on long-press from my laptop in any browser.

Phone model is Samsung S7 (non-edge) running latest OS.
11 days ago
Topic:
crash.

kent sager
kent sager
Posts: 10
kent sager
kent sager
Posts: 10
Topic: crash.
Chris Cicchitelli wrote:
Were you using the latest beta when this happened? Also, an uninstall actually leaves your config behind. If your config got corrupted during the crash, reinstalling it wouldn't fix it until it's deleted first. You can find the config in C:\ProgramData\CastleOS


I totally built a new version from scratch on a new box. Seems to run well so far.
12 days ago
Topic:
crash.

Chris Cicchitelli
Chris Cicchitelli
Administrator
Posts: 3376
Chris Cicchitelli
Chris Cicchitelli
Administrator
Posts: 3376
Topic: crash.
Were you using the latest beta when this happened? Also, an uninstall actually leaves your config behind. If your config got corrupted during the crash, reinstalling it wouldn't fix it until it's deleted first. You can find the config in C:\ProgramData\CastleOS
12 days ago
Topic:
License Key

Chris Cicchitelli
Chris Cicchitelli
Administrator
Posts: 3376
Chris Cicchitelli
Chris Cicchitelli
Administrator
Posts: 3376
Topic: License Key
Hi Kent, sorry about this. It does appear right clicks don't work on that box for pasting, however keyboard commands would, Ctrl + V. You could also try on a mobile device, where you can long press the box and press paste. If neither of those work, there is a manual way to add it to the configuration file, but you shouldn't have to do that...
12 days ago
Topic:
License Key

kent sager
kent sager
Posts: 10
kent sager
kent sager
Posts: 10
Topic: License Key
Put together a new computer to run my core service. Download and installed the latest build. Went to put in the License key and when I right click on the New License Key box I can not paste the key. This happened on my old computer too, I just ignored it because I knew I would migrate to a new box before the trial mode ran out. I can select and type in the new key box just can't right click and paste into it.
16 days ago
Topic:
crash.

kent sager
kent sager
Posts: 10
kent sager
kent sager
Posts: 10
Topic: crash.
I lost power to my COS core box. When I turned back on the config screen shows..An error occured loading the castloOS app. Please ensure the Core service is running. etc. etc.. Core service is running. Stopped, restarted nope.... Finally tried to fix via the install....no joy. Removed CastleOS (and my config I suppose) reloaded still the same message when I go to the config screen.
18 days ago
Topic:
remote hub

Chris Cicchitelli
Chris Cicchitelli
Administrator
Posts: 3376
Chris Cicchitelli
Chris Cicchitelli
Administrator
Posts: 3376
Topic: remote hub
kent sager wrote:
There was no link in the message. Please give me device name or a link.
Thanks.
Kent




Chris Cicchitelli wrote:
Hi Kent, I think this is what you are looking for, assuming you are looking for a pure ethernet Z-Wave interface and not simply using CastleOS as such. This device isn't supported in the current beta, but it will be later this month.

Likewise two controllers will be supported. The infrastructure is there in the current version but it hasn't been enabled yet.

Please feel free to ask questions and I'll clarify where I can!



Thanks!!!

-Chris




Sorry, it's there, but can be hard to see on some screens. Click here.
18 days ago
Topic:
remote hub

kent sager
kent sager
Posts: 10
kent sager
kent sager
Posts: 10
Topic: remote hub
There was no link in the message. Please give me device name or a link.
Thanks.
Kent




Chris Cicchitelli wrote:
Hi Kent, I think this is what you are looking for, assuming you are looking for a pure ethernet Z-Wave interface and not simply using CastleOS as such. This device isn't supported in the current beta, but it will be later this month.

Likewise two controllers will be supported. The infrastructure is there in the current version but it hasn't been enabled yet.

Please feel free to ask questions and I'll clarify where I can!



Thanks!!!

-Chris
19 days ago
Topic:
Kinect V2/voice control/ and your future direction

Robert Sims
Robert Sims
Posts: 3
Does Kinect v2 work yet? I am not able to determine that via the website. I am wanting to purchase a couple of them, but do not want to waste my money. How about gesture control? Has this been enabled? And motion detection etc.


Also since Microsoft is doing away with the Kinect, do you have another route you are heading for voice control? Can you use echo dots or google home?


And most importantly will your new direction still be cloudless or internal to my system? I do not like the idea of Alexa always listening and sending stuff to the cloud...
20 days ago
Topic:
remote hub

Chris Cicchitelli
Chris Cicchitelli
Administrator
Posts: 3376
Chris Cicchitelli
Chris Cicchitelli
Administrator
Posts: 3376
Topic: remote hub
Hi Kent, I think this is what you are looking for, assuming you are looking for a pure ethernet Z-Wave interface and not simply using CastleOS as such. This device isn't supported in the current beta, but it will be later this month.

Likewise two controllers will be supported. The infrastructure is there in the current version but it hasn't been enabled yet.

Please feel free to ask questions and I'll clarify where I can!


Thanks!!!

-Chris
20 days ago
Topic:
Lost Hub Log On Password

Chris Cicchitelli
Chris Cicchitelli
Administrator
Posts: 3376
Chris Cicchitelli
Chris Cicchitelli
Administrator
Posts: 3376
Topic: Lost Hub Log On Password
Hi Kent! You can find the configuration.xml file in the following directory. Please note it is hidden so you'll need to directly copy and paste this into your explorer, or enable "Show hidden files and folders" in your Explorer settings. C:\ProgramData\CastleOS\CastleOS Core Service

Thanks!!
20 days ago
Topic:
Lost Hub Log On Password

kent sager
kent sager
Posts: 10
I also have mis configured my admin password. A search does not show a configuration.xml file on my computer. A look in the castleos directory also does not show a configuration.xml file. Has it moved or been renamed in a later build?